środa, 15 lipca 2009

NetBeans 6.7 - fail dla php ?

Od paru dni korzystam z nowego NetBeansa w moim projekcie PHP i muszę szczerze przyznać, że jestem zawiedziony i to bardzo.
Po pierwsze wydajność - hmm sorry ale jakieś wielkiej różnicy w wydajności nie dostrzegłem. Features on Demand? No pomysł szczytny ale jakoś nadal nie widzę wzrostu wydajności - co więcej, gdy np. tworze nowy projekt Java ME/C++/cokolwiek i uruchamia się komponent za obsługę danej platformy odpowiedzialny trwa to spooooro czasu. Co ciekawe dysk jakoś w tym czasie nie pracuje dopiero na jakieś 2-3 sek przed samą aktywacją coś pomuli.
Wracając do PHP co mnie zdenerwowało:
- szybkość podpowiadania składni zwolniła bardzo mocno, mój kolega z zespołu po godzinie ją wyłączył, bo do niczego się nie nadawało - mam podobne wrażenia
- podpowiadanie składni potrafiło nawet nawalać w prostych przypadkach np. brak jakichkolwiek podpowiedzi o pola/metody klasy lub dziedziczonych
- ctrl+lewy klik przestał działać dla przypadków dla których działał w wersji 6.5
I teraz to co mnie zniszczyło... po uruchomieniu projektu korzystającego z SVN i próbie updatea netbeans poinformował mnie, że nie mam klienta. Poprosiłem go (bo była taka opcja) aby sam go ściągnął i zainstalował - dostałem komunikat, że jednak go MAM! No to super ponowna próba updatea i to samo! No to postanowiłem sam ściągnąć klienta i go zainstalować. Po podpięciu go pod NetBeans ten stwierdził, że jednak mam jego za starą wersję i nie będzie z nią działać . Ok, nagrałem najnowszą dostępna (1.6.cośtam). Znowu podpinanie i.... ! Teraz NetBeans twierdzi, że wszystkie pliki z projekcie są nowe, nie działają żadne ignore na katalogach a jakiekolwiek operacje ponownego ich zakładania nie przynoszą żadnego rezultatu. Jest fajnie!
Postanowiłem wywalić projekt i ściągnąć całość od nowa z SVN. Tym razem już miarka się przebrała, bo gdy chciałem połączyć się z serwerem pasek postępu po sekundzie w nieznanych okolicznościach znikał i nic nie mogłem zrobić.
Tyle od sfrustrowanego Łukasza i jego walk z NetBeansem. Wróciłem do 6.5 gdzie wszystko działa poprawnie.
Być może ja coś skopałem, czegoś nie skonfigurowałem, jestem głupi itp. ale używam tego środowiska od ponad roku i myślałem, że jednak taka operacja nie przysporzy problemów.

Nie testowałem jeszcze projektów Javowych w nowej wersji, ale w niedługim czasie to mam nadzieję nadrobię i liczę, że będzie ok.

A jakie Wy macie doświadczenia z nowym NB 6.7 ??

_
Dodam jeszcze, że pracuję na:
PC - Athlon X2 3800, 3GB RAMu, dysk 650GB SATA, win xp
oraz
Laptop - Core 2 Duo P8400, 4GB RAMu, Dysk 160GB SATA, vista
na obu te same doświadczenia.